MySQL 5.5.8 y PHP 5.3.4 ¡no son compatibles!

Este es un aviso a todos mis colegas desarrolladores, especialmente a aquellos que disfrutan de vivir en constante bleeding edge: Las versiones estables más recientes de MySQL y PHP, o sea, MySQL 5.5.8 y PHP 5.3.4, ¡no son compatibles entre ellas!

Lo anterior lo descubrió Ronald Bradford, experto en MySQL, al tratar de compilar desde su código fuente las versiones estables de PHP 5.3.4 con MySQL 5.5.8. Los detalles del error pueden leerlos en el Bug #58987.

Al parecer, si es posible lograr hacerlos funcionar juntos, pero se necesita modificar ciertas librerías y/o utilizar parámetros especiales al momento de compilar ambos componentes, lo cual obviamente no es lo óptimo. Esperemos que Oracle deje de pensar un rato en cómo ganar más dinero, y le dedique unos minutos en la corrección de este problema.

6 thoughts on “MySQL 5.5.8 y PHP 5.3.4 ¡no son compatibles!”

  1. Utilizo el MySQL 5.5.8 y el PHP 5.3.3 y me va sin problemas, no quise esta semana pasarme al 5.3.4 para probar porque ando liado de tiempo pero la próxima o el finde pruebo !

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>